Shared memory can be pinned to prevent paging and to reduce Input-Output overhead. To perform this, set the
LOCK_SGA
parameter to true
. On AIX 5L, the same parameter activates the large page feature whenever the underlying hardware supports it.Run the following command to make pinned memory available to Oracle Database:
$ /usr/sbin/vmo -r -o v_pinshm=1
Run a command similar to the following to set the maximum percentage of real memory available for pinned memory, where
percent_of_real_memory
is the maximum percent of real memory that you want to set:$ /usr/sbin/vmo -r -o maxpin%=percent_of_real_memory
When using the
maxpin%
option, it is important that the
amount of pinned memory exceeds the Oracle SGA size by at least 3
percent of the real memory on the system, enabling free pinnable memory
for use by the kernel.Use the
svmon
command to monitor the use of pinned memory
during the operation of the system. Oracle Database attempts to pin
memory only if the LOCK_SGA
parameter is set to true
.To turn on and reserve 10 large pages each of size 16 MB on a POWER4 or POWER 5 system, run the following command:
$ /usr/sbin/vmo -r -o lgpg_regions=10 -o lgpg_size=16777216
This command proposes bosboot and warns that a restart is required for the changes to take affect.
Oracle recommends specifying enough large pages to contain the entire SGA. The Oracle Database instance attempts to allocate large pages when the
LOCK_SGA
parameter is set to true
. If the
SGA size exceeds the size of memory available for pinning, or large
pages, then the portion of the SGA exceeding these sizes is allocated to
ordinary shared memory.
No comments:
Post a Comment